Weird network thing with files?

Before I pop this as an issue, I wanted to see if it is just me…

I have enabled the file sharing function on one of my HELM devices. When I am NOT on the same network (I have two completely separate broadband connections at home - one personal one work) everything works fine.

When I am on the same network - clients can not connect to the server for syncing. This is true for wired and wireless and for both PCs and mobile devices. I use the standard nextcloud clients on all my devices.

Is it just me?

This typically occurs if you are using networking equipment that does not support or has not enabled NAT loopback or hairpinning. We recommend checking with your cable modem and/or router support to see about whether this is supported and can be enabled.

Or add a “files” address on your DNS server that points to the internal IP address instead of relying on the public address. Try testing by going to the internal IP address from the same network?

1 Like

Can I access Nextcloud on Helm from a local IP address? It never seems to work for me. E.g., if I go to then nothing will load.

I have no problems accessing mine this way. Although you will get a cert error if you use an IP address instead of a URL.

Thanks everyone for the feedback. Appreciate the pointers.

Thank you for the advice. This issue plagues me as well.

I setup a Pi running DNSMasq to remedy the issue- unsuccessfully though…

I can ping/tracert to my local helm server ( routes me to the local IP of my helm, but I still cannot sync. Nor could I access the helm server by going straight to the local IP in a browser.

I checked, and much like @tms, I was also never able to access my nextcloud server by going straight to the local IP.

Any assistance would be greatly appreciated. Specifically, where should I direct the request “” to go to? Does port forwarding confuse this process?

I was using an Eero router when I first posted and I think there was something wrong with the NAT hairpinning. I’ve since swapped it out for an UBNT EdgeRouter PoE and it has worked great once port forwarding and firewall rules were in place.

Are you specifying the port in the browser (

I assume “$ dig” gets you an internal address and not the external address?

NAT should only be an issue if your re going out and back in to access the server. Or I guess if running NAT to connect some internal networks.

Yes, that dig command returns the local address - not the external. And still no look even when specifying the port in the address bar.

Currently, my workaround is to funnel all traffic through a VPN so all devices access the nextcloud server from an external address.

It’s truly confounding but I appreciate your time

Continuing the discussion from Weird network thing with files?:

So I think I may have figured out what is causing the problem. My home router is actually connected to a ISP-provided router/modem combo.

I wonder if this is what is stopping me from connecting on the LAN?

For info, I had to setup port forwarding on both routers to make it work correctly.

Ahh, so you do have double NAT! Does your ISP device have a bridge mode option, or can you just remove it?

Sorry for the delay. Yes, you’re right. Once I removed the isp hardware,and waited for the helm to get refresh its IP*, it all worked after that.
Thanks for the help

1 Like